top of page
Search

ASA - Initial Setup Examples

  • Writer: dale warner
    dale warner
  • Aug 22, 2024
  • 1 min read

This post details how to do some initial configuration setups on ASAs


Basic Setup (routed mode)

hostname ASA01
!
interface management 0/0
 ip address 192.168.90.81
 nameif MGMT
 security-level 0
 management-only
!
router management 0.0.0.0 0.0.0.0 192.168.90.254
!
ssh version 2
ssh key-exchange group dh-group14-sha1
ssh 0.0.0.0 0.0.0.0 MGMT
!
aaa authentication ssh console LOCAL

Transparent mode

firewall mode transparent
!
hostname ASA02
!
interface BVI 1
 ip address 172.30.21.50 255.255.255.0
!
interface GigabitEthernet0/0
 bridge-group 1
 nameif OUTSIDE
 security-level 0
 no shut
!
interface GigabitEthernet0/1
 bridge-group 1
 nameif INSIDE
 security-level 100
 no shut
!
access-list INSIDE-IN permit ip any any
access-group INSIDE-IN in interface INSIDE

Redundant Interface

hostname ASA03
!
interface gi0/0
 no shut
!
interface gi0/3
 no shut
!
interface redundant 1
 member-interface gi0/3
 member-interface gi0/0
 nameif INSIDE
 security-level 100
 ip address 192.168.31.10 255.255.255.0
 no shut

Recent Posts

See All
ASA - Clustering

Configuration examples for ASA Clustering Individual interfaces (L3) Clustering Master Unit cluster interface-most indiviual force ! ip...

 
 
ASA - Contexts

Configuration example of setting up ASA contexts mode multiple ! mac-address auto ! interface g0/1 no shut interface g0/2 no shut...

 
 
ASA - High Availability

Some configuration examples related to Cisco ASA HA (Active/Passive and Active/Active) Active/Passive Failover - Same Failover & State...

 
 
bottom of page